HP LaserJet 1018 en Debian Buster (testing)


#1

Tengo un problema con mi impresora. Tengo que decir que tiene ya sus añitos, y quizás me vendría bien incluso comprarme otra, pero ahora ni es el momento ni me apetece jubilarla.

A ver, el problema reside en que, desde que actualicé a Debian Buster, es incapaz de imprimir nada. No parece ser tema de drivers, porque el sistema me la reconoce de miedo. He intentado imprimir una página de prueba de la siguiente manera:

$ (lspci && lsusb) > devices.txt | lp devices.txt

Y aunque parece que el sistema manda la orden de imprimir, porque recibo la notificación, al instante me dice que impresión terminada, y cero páginas impresas.

¿Alguien ha tenido un problema similar? Adelanto que los paquetes printer-driver-foo2zjs, cups y psutils están instalados y actualizados a la última versión disponible en los repositorios.


#2

Conectada por cable o WiFi?


#3

[SrFreak] SrFreak http://foro.hacklabalmeria.net/u/srfreak
22 Octubre

Tengo un problema con mi impresora. Tengo que decir que tiene ya sus
añitos, y quizás me vendría bien incluso comprarme otra, pero ahora ni
es el momento ni me apetece jubilarla.

Y, si funciona, ¿para que la vas a jubilar?

A ver, el problema reside en que, desde que actualicé a Debian Buster,
es incapaz de imprimir nada. No parece ser tema de drivers, porque el

[…]

¿Alguien ha tenido un problema similar? Adelanto que los paquetes
|printer-driver-foo2zjs|, |cups| y |psutils| están instalados y
actualizados a la última versión disponible en los repositorios.

Por cualquier problema de impresoras que nombres, seguro que ya he pasado.

A mi me parece que te falla algo del sistema de impresión, ya sea el
filtro, el pre-procesador… cualquier cosa.

¿Que te marcan los registros de errores de Cups? Si no marca nada,
aumenta el nivel de salida a depuración:

LogLevel debug

A ver si por ahí eres capaz de tirar del hilo.

Salud y Revolución.

Lobo.


#4

Es una impresora del año catapún, me suena que la compramos antes de terminar yo la ESO, así que puede ser perfectamente del año 2007-2008. Poco WiFi ahí xD

Técnicamente la impresión finaliza con éxito, pero vamos que no sale nada. Voy a probar a aumentar el nivel de depuración de Cups y te digo, porque mira que es un problema raro…


#5

Desde la interfaz web de CUPS, puedo sacar que el error es

stopped “Filter failed”

Una búsqueda en Internet 1, junto con otros datos que he recopilado en mis andanzas, me indican que lo más probable es hplip todavía no soporte Debian Buster. Pero me parece muy raro que ni si quiera usando el driver Foo2ZJS sea capaz de echar a andar, con el mismo error.


#6

En muchos casos, los cartuchos comienzan a subir de precio respecto al de modelos más modernos y a larga es más económico compararte otra nueva, además de otras ventajas inherentes de los modelos más avanzados, como mayor calidad, imprimir desde tarjetas, conexión con el smartphone…

¿Estás usando hplip para instalar la impresora? Una de las ventajas de las HP es su gran soporte con el pingüino mediante hplip-setup y demás.


#7

Si, y me dice que mi distribución esta fuera de las soportadas.


#8

[MiguelAngelLV] MiguelAngelLV
http://foro.hacklabalmeria.net/u/miguelangellv
23 Octubre

Razlobo:

Y, si funciona, ¿para que la vas a jubilar?

En muchos casos, los cartuchos comienzan a subir de precio respecto al
de modelos más modernos y a larga es más económico compararte otra
nueva, además de otras ventajas inherentes de los modelos más avanzados,
como mayor calidad, imprimir desde tarjetas, conexión con el smartphone…

¿Obsolescencia programada, inducida y consentida?

Para rellenar los tóner hay «polvos», así que si suben, lo curas a
polvos. ;^)

@jsalvador, ¿porque le das un vistazo al filtro y miras a ver que te falta?

Salud y Revolución.

Lobo.


#9

No siempre, también es por mejoras y eficiencias. Es como los coches, los nuevos consumen menos además de otras prestaciones.


#10

No le hemos cambiado el tóner desde que se compró. En cuanto la tenga a mano otra vez, intentaré arreglarla, pero con la mudanza y todo eso, casi que me sale interesante comprarme otra nueva.


#11

[MiguelAngelLV] MiguelAngelLV
http://foro.hacklabalmeria.net/u/miguelangellv
23 Octubre

Razlobo:

¿Obsolescencia programada, inducida y consentida?

No siempre, también es por mejoras y eficiencias. Es como los coches,
los nuevos consumen menos además de otras prestaciones.

Y como consumen menos haces más kilómetros, es la paradoja de Jevons:

Si imprimes 10.000 copias al mes, me puede valer lo de las mejoras y
eficiencias, si imprimes 3 páginas al mes, no me vale.

Salud y Revolución.

Lobo.


#12

Lo que vale, es que funcione. Todo lo que compres tiene obsolescencia programada, no puedes escapar. Si los recambios son más caros o difíciles de encontrar no merece la pena. Además, de entrada ya no es compatible, asi que lo suyo es adquirir otra impresora, que te dé más facilidades.


#13

Compatible es. Pero yo estoy usando Debian testing/Sid, no Stable. El paquete de drivers de hplip está diseñado para stable. De hecho, llega hasta 9.1 (yo tengo Debian 10). La idea de comprarme una nueva es que, esta le viene mejor a mi padre. Yo imprimo unas 3-4 páginas al mes, pero las impresoras actuales no valen tampoco mucho.


#14

Entonces creo que te sale mucho más rentable no tener ninguna e ir a alguna papelería y dejarte de preocupaciones.


#15

¿Y esto? https://packages.debian.org/buster/hplip


#16

Sí, y me dice que mi distribución está fuera de las soportadas.


#17

[MiguelAngelLV] MiguelAngelLV
http://foro.hacklabalmeria.net/u/miguelangellv
24 Octubre

SrFreak:

El paquete de drivers de hplip está diseñado para stable. De hecho,
llega hasta 9.1 (yo tengo Debian 10).

¿Y esto? https://packages.debian.org/buster/hplip

$ rmadison hplip
hplip      | 3.12.6-3.1+deb7u1        | oldoldstable       | source,
amd64, armel, armhf, i386, ia64, kfreebsd-amd64, kfreebsd-i386, mips,
mipsel, powerpc, s390, s390x, sparc
hplip      | 3.14.6-1                 | oldstable-kfreebsd | source
hplip      | 3.14.6-1+b2              | oldstable-kfreebsd |
kfreebsd-amd64, kfreebsd-i386
hplip      | 3.14.6-1+deb8u1          | oldstable          | source,
amd64, arm64, armel, armhf, i386, mips, mipsel, powerpc, ppc64el, s390x
hplip      | 3.16.11+repack0-1~bpo8+1 | jessie-backports   | source,
amd64, arm64, armel, armhf, i386, kfreebsd-amd64, kfreebsd-i386, mips,
mipsel, powerpc, ppc64el, s390x
hplip      | 3.16.11+repack0-3        | stable             | source,
amd64, arm64, armel, armhf, i386, mips, mips64el, mipsel, ppc64el, s390x
hplip      | 3.17.7+repack0-3         | unstable           | source,
hurd-i386, kfreebsd-amd64, kfreebsd-i386
hplip      | 3.17.7+repack0-3         | unstable-debug     | source
hplip      | 3.17.9+repack0-1         | testing            | source,
amd64, arm64, armel, armhf, i386, mips, mips64el, mipsel, ppc64el, s390x
hplip      | 3.17.10+repack0-1        | unstable           | source,
amd64, arm64, armel, armhf, i386, mips, mips64el, mipsel, powerpc,
ppc64el, s390x
hplip      | 3.17.10+repack0-1        | unstable-debug     | source

Hplip esta para todas las versiones de Debian, no entiendo la parte que
dice @jsalvador de que no esta «soportado» para su versión. :^m

Salud y Revolución.

Lobo.


#18

Probé con ese paquete, precisamente. Y hp-setup me dice eso… Hasta 9.1

Ya lo investigare otra vez cuando tenga tiempo, pero me va ganando la impresora.