Instalar MongoDB en Debian 10.0


#1

Ayer empecé a preparar el entorno para el curso M001 de MongoDB, sobre Debian 10.0.0, la release estable. Ya había leído que MongoDB estaba disponible nativamente en Debian 10, pero o entendí mal o lo que se cuenta no es del todo verdad. El caso es que no daba con la tecla para añadir el repositorio de mongodb-org necesario.

Pero lo conseguí usando el de “Ubuntu Bionic Multiverse”. Si os corre prisa tenerlo disponible, podéis tirar adelante con esta solución, hasta que apaezca un repositorio oficial para Debian 10.

Los pasos para conseguirlo son:

Atención: todos los pasos se harán con cuenta #root ( su - ) tenedlo en cuenta. O eso, o instaláis y usáis sudo.

Añadir la firma digital para repositorio que vamos a usar

# apt-key adv --keyserver hkp://keyserver.ubuntu.com:80 --recv 9DA31620334BD75D9DCB49F368818C72E52529D4 

Añadir a apt el repositorio ubuntu bionic/mongodb-org/4.0 multiverse

# echo "deb http://repo.mongodb.org/apt/ubuntu bionic/mongodb-org/4.0 multiverse" | tee /etc/apt/sources.list.d/mongodb.list 

Actualizar el contenido de paquetes disponibles en los repositorios.

# apt-get update

Ign:4 http://repo.mongodb.org/apt/ubuntu bionic/mongodb-org/4.0 InRelease
Obj:5 http://repo.mongodb.org/apt/ubuntu bionic/mongodb-org/4.0 Release

Instalar el paqeute mongodb-org (y sus dependencias)

# apt-get install mongodb-org

El producto está instalado, pero no está en ejecución. Ahora es importante no ejecutar el daemon directamente para evitar que los directorios necesarios ( /var/log/mongodb, /var/lib/mongodb, …) se creen con “root” como owner.

Ahora registraremos el servicio con systemctl y lo levantaremos por defecto

# systemctl enable mongod.service
# systemctl start mongod.service

Dejamos de usar el usuario root y ya podemos usar mongo

# exit
$ mongo
MongoDB shell version v4.0.11
connecting to: mongodb://127.0.0.1:27017/?gssapiServiceName=mongodb
Implicit session: session { "id" : UUID("9679aa98-df04-458b-a100-b2f01085a68f") }
MongoDB server version: 4.0.10
Server has startup warnings:
2019-07-25T17:52:11.837+0200 I STORAGE  [initandlisten]
2019-07-25T17:52:11.837+0200 I STORAGE  [initandlisten] ** WARNING: Using the XFS filesystem is strongly recommended with the WiredTiger storage engine
2019-07-25T17:52:11.837+0200 I STORAGE  [initandlisten] **          See http://dochub.mongodb.org/core/prodnotes-filesystem
2019-07-25T17:52:13.581+0200 I CONTROL  [initandlisten]
2019-07-25T17:52:13.581+0200 I CONTROL  [initandlisten] ** WARNING: Access control is not enabled for the database.
2019-07-25T17:52:13.581+0200 I CONTROL  [initandlisten] **          Read and write access to data and configuration is unrestricted.
2019-07-25T17:52:13.581+0200 I CONTROL  [initandlisten]
2019-07-25T17:52:13.581+0200 I CONTROL  [initandlisten]
2019-07-25T17:52:13.581+0200 I CONTROL  [initandlisten] ** WARNING: /sys/kernel/mm/transparent_hugepage/enabled is 'always'.
2019-07-25T17:52:13.581+0200 I CONTROL  [initandlisten] **        We suggest setting it to 'never'
2019-07-25T17:52:13.581+0200 I CONTROL  [initandlisten]

Enable MongoDB's free cloud-based monitoring service, which will then receive and display
metrics about your deployment (disk utilization, CPU, operation statistics, etc).

The monitoring data will be available on a MongoDB website with a unique URL accessible to you
and anyone you share the URL with. MongoDB may use this information to make product
improvements and to suggest MongoDB products and deployment options to you.

To enable free monitoring, run the following command: db.enableFreeMonitoring()
To permanently disable this reminder, run the following command: db.disableFreeMonitoring()

Ya queda pendiente seguir las recomendaciones del párrafo, pero no lo tocaré hasta comenzar el curso.


#2

Bueno, como es de esperar, no está MongoDB 4.0, pero estar, está en los repos de Debian desde Jessie

https://packages.debian.org/stretch/mongodb

Donde parece que no ha pasado el filtro ha sido en Buster.


#3

Instálalo usando docker, te quitarás de problemas.


#4

Este tema se cerró automáticamente 20 días después del último post. No se permiten nuevas respuestas.